Управление шаблонами

Диалоговое окно диспетчера шаблонов облегчает управление шаблонами и позволяет создавать новые документы с помощью шаблонов.

Доступ к этой команде

Из главного меню:

Выберите меню Файл - Создать – Шаблоны.

Выберите меню Файл – Шаблоны – Управление шаблонами.

Из центра запуска:

Выберите шаблон любого типа с помощью кнопки Шаблоны в центре запуска.

Нажмите кнопку Шаблоны в центре запуска.

С клавиатуры:

Нажмите +Shift+N в любом модуле LibreOffice.


Шаблоны позволяют сэкономить время на редактирование, так как создают заполненные предварительным содержанием и отформатированные документы. Диспетчер шаблонов в LibreOffice позволяет получать доступ к шаблонам и организовывать их.

LibreOffice изначально содержит набор встроенных шаблонов, которые можно использовать для создания документов, презентаций, электронных таблиц или рисунков. Можно использовать шаблоны из диспетчера шаблонов, создавать свои собственные шаблоны или найти дополнительные шаблоны в Интернете.

Значок подсказки

Для организации шаблонов используйте категории. Создавайте новые или загружайте готовые шаблоны и управляйте ими в диспетчере шаблонов. Используйте шаблоны для экономии времени при работе с повторяющимися документами.


Главное окно – Выбор шаблона

Миниатюры доступных шаблонов выводятся в главное окно на основе заданного поискового запроса и выбранного фильтра. Дважды щёлкните по значку любого шаблона для создания документа с заданным в шаблоне содержимым и форматированием.

Выберите Миниатюры или Список в нижней части окна слева, чтобы изменить вариант отображения шаблонов.

Значок «Миниатюры»

Миниатюры

Значок «Список»

Список

Значок примечания

Для отображения шаблонов из другой папки в категории Мои шаблоны выберите LibreOffice - Пути, выберите Шаблоны, нажмите кнопку Правка, затем нажмите кнопку Добавить, после чего появится диалог открытия файла, в котором нужно выбрать подходящую папку.


Поиск

Поиск шаблонов можно выполнять по тексту, вводимому в поле поиска вверху слева. Найденные шаблоны появляются в главном окне.

Фильтр

Имеются следующие варианты фильтрации: Все приложения, Текстовые документы, Электронные таблицы, Презентации или рисунки, которые можно выбрать из раскрывающегося списка вверху по центру. Отфильтрованные шаблоны появляются в главном окне.

Категории

Категории представляют собой папки, в которые помещаются шаблоны. Все шаблоны размещаются по категориям, но могут быть помещены только в одну из них. Выбирать можно следующие категории по умолчанию: Все категории, Мои шаблоны, Деловая корреспонденция, MediaWiki, Прочие деловые документы, Личная корреспонденция и документы, Презентации или Стили. Также можно создать новую категорию для личного использования. Нажмите Управление в правом углу сверху диспетчера шаблонов, затем выберите Создать категорию для создания новой категории.

Пользовательские шаблоны можно перемещать, а встроенные шаблоны — копировать в другую категорию. Для этого используется команда Переместить, которая находится в меню, вызываемом щелчком правой кнопки мыши по отдельному шаблону.

Значок примечания

Вложенные категории не допускаются.


Управление

Нажмите Управление в верхнем правом углу, чтобы открыть соответствующее меню. Меню содержит следующие пункты: Создать категорию, Импорт и Расширения. Если шаблон задан по умолчанию, появляется пункт Сбросить на шаблон по умолчанию. При выборе пользовательской категории также появляются пункты Переименовать категорию и Удалить категорию.

Создать категорию

Выберите эту команду, чтобы создать категорию для размещения шаблона.

Значок «Создать категорию»

Создать категорию

Сбросить на шаблон по умолчанию

Этот пункт появляется только тогда, когда в качестве шаблона по умолчанию был задан пользовательский шаблон. Команда используется для возврата к стандартной конфигурации. С помощью меню Фильтр укажите приложение, для которого нужно выполнить сброс. Выберите в фильтре параметр Все приложения, чтобы вернуть шаблоны по умолчанию для всех приложений.

Импорт

Чтобы импортировать один или несколько шаблонов в Диспетчер шаблонов, выберите Импорт, категорию шаблона в диалоговом окне Выбор категории, после чего выберите импортируемые файлы.

Значок «Импорт»

Импорт

Расширения

Для обзора других шаблонов в Интернете выберите «Расширения», чтобы открыть окно поиска. Искать шаблоны можно также на веб-странице https://extensions.libreoffice.org.

Значок «Расширения»

Расширения

Действия с отдельными шаблонами

Создать из шаблона

Выберите шаблон в главном окне, щёлкните правой кнопкой мыши и выберите Открыть, нажмите клавишу Enter или дважды щёлкните для создания документа с помощью этого шаблона.

Также можно использовать кнопку Создать из шаблона справа внизу, чтобы создать документ с помощью выбранного шаблона.

Создать из шаблона

Создать из шаблона

Редактировать шаблон

Выберите шаблон в главном окне, щёлкните правой кнопкой мыши и выберите Редактировать шаблон, чтобы отредактировать его. Для встроенных шаблонов возможно редактирование копии.

Значок «Редактировать шаблон»

Редактировать шаблон

Установить по умолчанию

Выберите шаблон в главном окне, щёлкните правой кнопкой мыши и выберите «Установить по умолчанию» для установки шаблона в качества шаблона по умолчанию. При этом рядом с выбранным шаблоном появится зелёный флажок и шаблон будет автоматически загружаться при создании документа с помощью соответствующего приложения.

Значок «Установить по умолчанию»

Установить по умолчанию

Переименовать

Для переименования шаблона выберите его в главном окне, щёлкните правой кнопкой мыши и выберите «Переименовать». Появится диалоговое окно, в котором можно выбрать новое имя для шаблона. Введите имя и нажмите кнопку OK, либо «Отменить», чтобы оставить заданное имя.

Значок «Переименовать»

Переименовать

Удалить

Выберите один или несколько удаляемых шаблонов в главном окне и нажмите клавишу Delete или щёлкните правой кнопкой мыши и выберитеУдалить для удаления выбранного шаблона (шаблонов). Появится диалоговое окно с запросом подтверждения. Выберите Да для удаления или Нет для отмены.

Значок «Удалить»

Удалить

Значок примечания

Встроенные шаблоны нельзя изменять, переименовывать или удалять.


Переместить

Для перемещения шаблонов в другой каталог выберите шаблон или нажмите клавишу +щелчок мыши, чтобы выбрать другие шаблоны, затем щёлкните правой кнопкой мыши и выберите Переместить, чтобы открыть диалоговое окно Выбор категории, где можно выбрать целевой каталог или новую категорию для перемещения шаблона. Встроенные шаблоны перемещать нельзя, но можно создавать их копии в других категориях.

Значок «Переместить»

Переместить

Экспорт

Выберите шаблон в главном окне или нажмите клавишу +щелчок мыши, чтобы выбрать другие шаблоны, затем щёлкните правой кнопкой мыши и выберите «Экспорт» для экспорта выбранных шаблонов в папку на данном компьютере.

Значок «Экспорт»

Экспорт

Значок подсказки

Для перемещения или экспорта всех шаблонов в Категории нажмите +A, затем выберите Переместить или Экспорт.


Примеры

Пример 1 – Создание делового письма

  1. Открыть LibreOffice Writer

  2. Нажмите +Shift+N или выберите Файл - Создать - Шаблоны, чтобы открыть диспетчер шаблонов

  3. Введите «деловое письмо» в поле поиска

  4. Выберите один из шаблонов в главном окне двойным щелчком или выделите его и нажмите клавишу Enter.

  5. Новый документ из этого шаблона создаётся в новом экземпляре LibreOffice Writer

  6. Измените текст и логотип при необходимости

Пример 2 – Импорт шаблона – Электронная таблица личного бюджета

  1. Открыть LibreOffice Calc

  2. Нажмите клавишу +Shift+N или выберите Файл - Создать - Шаблоны, чтобы открыть диспетчер шаблонов

  3. Щёлкните по элементу Управление и выберите «Расширения» для просмотра шаблонов онлайн.

  4. Найдите шаблон личного бюджета и загрузите его

  5. Откройте диспетчер шаблонов и выберите кнопку «Импорт»

  6. Выберите категорию, в которой будет храниться новый шаблон. Например, Мои шаблоны, и нажмите кнопку OK.

  7. Найдите папку, в которую был загружен шаблон, выберите её и нажмите «Открыть»

  8. Теперь шаблон доступен в выбранной категории.

Пример 3 – LibreOffice Impress – Шаблон презентации

  1. Открыть LibreOffice Impress

  2. Диспетчер шаблонов открывается автоматически при открытии LibreOffice Impress

  3. Выберите шаблон для презентации, отфильтруйте по категориям или тексту поиска

  4. Также можно воспользоваться контекстным меню, импортировать шаблон или найти его онлайн.

  5. Когда диспетчер шаблонов открывается первый раз автоматически, несколько функций в нём будут недоступны. Для получения доступа ко всем функциям можно снова открыть диспетчер шаблонов после запуска LibreOffice Impress.

См. шаблоны для загрузки на https://extensions.libreoffice.org.

См. Создание шаблона документа для получения дополнительной информации.

См. Шаблоны и стили для получения дополнительной информации.

Пожалуйста, поддержите нас!

Пожалуйста, поддержите нас!